Redstone Mapper stuck on pub get


I added redstone_mapper in my dependencies and run pub get then it got stuck on resolving dependencies…

Here’s my pubspec.yaml

name: sample
version: 0.0.1
description: SAMPLE
author: Joes
  sdk: '>=1.5.0 <2.0.0'
  appengine: '>=0.3.0 <0.4.0'
  browser: '>=0.10.0 <0.11.0'
  polymer: '>=0.16.0 <0.17.0'
  paper_elements: '>=0.7.0 <0.8.0'
  redstone: '>=0.6.0-beta.1 <0.7.0'
  redstone_mapper: '0.2.0-beta.1 <0.3.0'
  shelf: '>=0.6.0 <0.7.0'
  shelf_static: '>=0.2.0 <0.3.0'
  shelf_rpc: '>=0.0.0 <0.1.0'
  route_hierarchical: '>=0.6.0 <0.7.0'
  sass: '>=0.4.0 <0.5.0'
  dartson: '>=0.2.0 <0.3.0'
  test: any
  - sass/inlined_sass_transformer
  - dartson
  - polymer:
      entry_points: web/index.html
  - $dart2js:
      minify: true
      $exclude: bin/**.dart
      $include: '**/*.polymer.bootstrap.dart'
  - test/pub_serve:
      $include: test/**_test{.*,}.dart

This happens when i run pub get with redstone_mapper, but without redstone_mapper it works fine

Joe's-Mac-mini:sample joe$ pub get
Resolving dependencies... (1:7.6s) 
Resolving dependencies... (1:9.4s) 
Resolving dependencies... (1:24.1s) 


redstone_mapper 0.2.0-beta.1 isn’t compatible with test. But I haven’t yet found why. The error message I get doesn’t help either.

According to this message it looks like redstone_mapper depends on a too old analyzer version

Resolving dependencies... (2.0s) 
Incompatible version constraints on analyzer:
- redstone_mapper 0.2.0-beta.1 depends on version >=0.15.6 <0.23.0
- test 0.12.0-beta.2 depends on version >=0.23.0 <0.25.0

but the pubspec.yaml in the GitHub repo of redstone_mapper shows analyzer: '>=0.15.6 <0.26.0' which would also allow 0.25.0.
Maybe redstone_mapper was deployed with a different pubspec.yaml or there might be a bug in pub.

See also this open issue

Answered By – Günter Zöchbauer

Answer Checked By – Dawn Plyler (FlutterFixes Volunteer)

Leave a Reply

Your email address will not be published. Required fields are marked *