ext.kotlin_version = <'latest version'> error on Flutter

Issue

I am trying to place advertising in my flutter app, this is proving to be almost more complicated for me than creating the app itself (I am a newbie dev starting with flutter).

I get an error when I try to launch my app that says the following: [!] Your project requires a newer version of the Kotlin Gradle plugin. Find the latest version on https://kotlinlang.org/docs/gradle.html#plugin-and-versions, then update C:\Users\User\Desktop\Dev\adtest\android\build.gradle: ext.kotlin_version = ” Exception: Gradle task assembleDebug failed with exit code 1

The problem seems simple, I have to update the field suggested by the console. My surprise is that the field ext.kotlin_version = " ", does not exist in my build.grade file on android/build.gradle. Neither does the buildscript { } apatagate exist that should contain it. I have android Studio installed, Flutter updated, I work with visual studio code, everything is apparently correct, except for this.

Thanks for your help.

Solution

I was facing the same error and resolved it by this method. I hope this will also for you. Just follow these steps

  • open your terminal
  • run -> dart pub outdated (it will show you all outdated versions of the project)
  • run -> dart pub upgrade –major-versions
  • restart your android studio

Answered By – Syed Vkax

Answer Checked By – Pedro (FlutterFixes Volunteer)

Leave a Reply

Your email address will not be published.