Is AngularDart 4 compatible with Dart 2 & build_runner 0.8?


Currently on

  • Dart VM version: 2.0.0-dev.49.0
  • angular ^4.0.0
  • Linux
  • Dartium

One of the upgrade requirement for Dart 2 upgrade @ is to use build_runner 0.8 which from the error code is not compatible with Angular4.

My pubspec.yaml looks like

name: JRapha
description: A web app that uses AngularDart Components
version: 0.0.1
  sdk: '>=2.0.0-dev.49.0 <2.0.0'
  angular: ^4.0.0
  angular_test: ^1.0.0
  test: ^0.12.30
  build_runner: ^0.8.2
  build_test: ^0.10.1
  build_web_compilers: ^0.3.6
    debug: dartdevc

The Error when running pub get

Because angular_compiler >=0.2.1 <0.3.0+1 depends on build ^0.10.0 and no versions of angular_compiler match >0.3.0+1 <0.4.0, angular_compiler >=0.2.1 <0.3.0+1 or >0.3.0+1 <0.4.0 requires build ^0.10.0.
And because angular >=4.0.0-beta <5.0.0-alpha depends on angular_compiler ^0.3.0, angular >=4.0.0-beta <5.0.0-alpha requires build ^0.10.0 or angular_compiler 0.3.0+1. And because angular_compiler 0.3.0+1 depends on build >=0.10.0 <0.12.0 and build_web_compilers >=0.2.1 depends on build ^0.12.0, angular >=4.0.0-beta <5.0.0-alpha is incompatible with
build_web_compilers >=0.2.1.
So, because JRapha depends on both angular ^4.0.0 and build_web_compilers ^0.3.6, version solving

Is there a solution to running AngularDart4 with Dart v2?


No, it is not compatible.

Only AngularDart v5 is compatible with Dart2 and build_runner.

Answered By – matanlurey

Answer Checked By – David Marino (FlutterFixes Volunteer)

Leave a Reply

Your email address will not be published. Required fields are marked *