flutter_plugin_pdf_viewer >=1.0.4 is forbidden


I’m installing 2 packages: rxdart and flutter_plugin_pdf_viewer

rxdart: ^0.23.1
flutter_plugin_pdf_viewer: ^1.0.7

but flutter_plugin_pdf_viewer >=1.0.4 is forbidden.

and this is error message:

Because flutter_plugin_pdf_viewer >=1.0.4 depends on rxdart ^0.21.0 and flutterattendancesystem depends on rxdart ^0.23.1, flutter_plugin_pdf_viewer >=1.0.4 is forbidden.

So, because flutterattendancesystem depends on flutter_plugin_pdf_viewer ^1.0.7, version solving failed.
pub upgrade failed (1; So, because flutterattendancesystem dep
ends on flutter_plugin_pdf_viewer ^1.0.7, version solving failed.)


Look at this thread https://github.com/CrossPT/flutter_plugin_pdf_viewer/issues/59

This repo is not maintained properly,
You can use a different package for pdf viewer.

or for a temporary fix do a following

Manually edit the pubspec.yaml in flutter_plugin_pdf_viewer-1.0.7 folder in .pub-cache and set rxdart: ^0.21.0 to rxdart: ^0.23.1.

In flutter_plugin_pdf_viewer-1.07/lib/src/document.dart at line no: 89, changed Observable to Stream.

Answered By – Alex Sunder Singh

Answer Checked By – Mary Flores (FlutterFixes Volunteer)

Leave a Reply

Your email address will not be published. Required fields are marked *