I’m currently trying to study using flutter riverpod but i get a problem when i’m trying to put flutter_riverpod package i get this error
Because riverpod depends on flutter_riverpod ^0.9.1 which depends on riverpod ^0.8.0, riverpod ^0.8.0 is required. So, because riverpod is 1.0.0+1, version solving failed. Running "flutter pub get" in riverpod... pub get failed (1; So, because riverpod is 1.0.0+1, version solving failed.)
What can i do to fix this problem? I tried to add riverpod package but it’s also not working
See this decision tree created by the developer of riverpod for which version to install.
You only want to install one riverpod dependency.
If you are writing pure dart code (no Flutter), then install riverpod.
To reiterate, your pubspec.yaml should only ever include one riverpod dependency.
If you still have version solving issues with your dependencies after this then try deleting your pubspec.lock and reinstall your dependencies.
Answered By – Alex Hartford
Answer Checked By – Jay B. (FlutterFixes Admin)