Are Dart 1 books still relevant for learning Dart 2

Issue

I read on many places that Dart 2 is not completely backward compatible with Dart. I found a list of books that are for Dart 1.x

https://dart.dev/resources/books

Can someone with Dart 1 and Dart 2 experience tell me if this books are relevant for learning Dart 2, can I use them or I should wait for release of some Dart 2 book.

I am not sure that this is the relevant place for this type of question, but I did’t found anything more suiting in the Stack Exchange network.

Solution

Yes sure it is relevant. For the language instance creation keywords like new and const have become optional to help declutter the code. They’ve made a number of small changes and done some cleanup on the dart core libraries. Nothing huge to worry about 🙂

Answered By – Khalil

Answer Checked By – Mary Flores (FlutterFixes Volunteer)

Leave a Reply

Your email address will not be published.