TravisCI – ERR : Package flute_music_player requires Flutter SDK version ^0.1.2 but the current SDK is 0.0.0-unknown

Issue

I am new travis and started working on it with flutter.

I am using flute_music_player plugin for my music player app.

Now app is working/building fine locally on my machine but I cant build it on Travis

Here is what I get

    $ ./flutter/bin/flutter test
    Running "flutter packages get" in tumultus...             
    Package flute_music_player requires Flutter SDK version ^0.1.2 but the current SDK is 0.0.0-unknown.
    ---- Log transcript ----
.
.
.
.
---- End log transcript ----
pub get failed (1)
The command "./flutter/bin/flutter test" exited with 1.
store build cache
nothing changed, not updating cache
Done. Your build exited with 1.

Here is the link to my complete Job log.

And my travis.yml is :

os:
  - linux
sudo: false
addons:
  apt:
    # Flutter depends on /usr/lib/x86_64-linux-gnu/libstdc++.so.6 version GLIBCXX_3.4.18
    sources:
      - ubuntu-toolchain-r-test # if we don't specify this, the libstdc++6 we get is the wrong version
    packages:
      - libstdc++6
      - fonts-droid
before_script:
  - git clone https://github.com/flutter/flutter.git -b alpha --depth 1
  - ./flutter/bin/flutter doctor
script:
  - ./flutter/bin/flutter test
cache:
  directories:
    - $HOME/.pub-cache

My complete project can be found on github here

Actually I have copied most of the code from here and I tried to run his project on travis but same error on log.

Is there anywhere I am lacking, please help.

Thanks for any help or suggestions in advance.

Solution

Alright the Issue was with plugin version not actually Travis.

Answered By – Sahdeep Singh

Answer Checked By – Marilyn (FlutterFixes Volunteer)

Leave a Reply

Your email address will not be published.