I am trying to get packages from the PUB with the following:
name: 'ch_padart' version: 0.0.1 dependencies: angular: "1.1.0" angular_node_bind: any polymer: ">=0.15.5+2 <0.16.0" core_elements: ">=0.6.0+4 <0.7.0" paper_elements: ">=0.6.1 <0.7.0" web_components: ">=0.9.0 <0.11.0" browser: ">=0.10.0+2 <0.11.0" dev_dependencies: unittest: ">=0.11.0+5 <0.12.0" mock: ">=0.11.0+2 <0.12.0" transformers: - angular: html_files: - web/index.html - polymer: entry_points: web/index.html lint: false
but the end result is always ‘Connection closed before full header was received’
If you remove angular OR polymer (and elements) and then run pub get, there is no issue and all download and runs fine. No other warnings are displayed and –verbose yields nothing helpful that I can see.
When you run
pub get -v from command line you will see that pub is working quite hard but can’t find a compatible set of dependencies. There was a similar issue recently that the I guess the collection package was required in different dependencies with non-overlapping version constraints.
This is quite common when using Angular with Polymer.
You might need to investigate the dependencies manually to find the cause.
Maybe you get some feedback from
pub get when you remove all dependency constraints and then start adding them again one by one.
Answered By – Günter Zöchbauer
Answer Checked By – Timothy Miller (FlutterFixes Admin)