I would like to use dart SDK: “>=2.6.0 <3.0.0” with flutter. But my current version of dart used by Flutter is 2.5.0.
flutter upgrade my flutter version is:
flutter --version Flutter 1.9.1+hotfix.6 • channel stable • https://github.com/flutter/flutter.git Framework • revision 68587a0916 (3 months ago) • 2019-09-13 19:46:58 -0700 Engine • revision b863200c37 Tools • Dart 2.5.0
I have tried to download the latest stable release of Flutter SDK(2.6.1) from the link and replace it with the already available dart-sdk inside flutter > bin > cache > dart-sdk but after this steps I am getting below error:
Wrong full snapshot version, expected 'cb187597a166f2c0c64a200e22509ee3' found 'c8562f0ee0ebc38ba217c7955956d1cb' Isolate creation failed
Is there any other way to solve these issues and upgrade dart-sdk in flutter?
Flutter only supports Dart 2.5 rigth now. There is now way to support 2.6. You will have to wait for a new Flutter release to support newer versions of Dart.
Answered By – Tidder
Answer Checked By – Clifford M. (FlutterFixes Volunteer)