I tried to use null safety, but it’s giving me this error:
This requires the ‘non-nullable’ language feature to be enabled. Try
updating your pubspec.yaml to set the minimum SDK constraint to 2.10.0
or higher, and running ‘pub get’.
I changed my Dart SDK constraint from
2.10.0, but it’s still showing this error.
Also, I upgraded my Dart and Flutter SDK:
dart-sdk v2.10.2 is the latest version available based on your
Flutter (Channel stable, 1.22.3, …
To Enable null safety,
Check Latest Dart Version(It should be Dart 2.12 or later:)
Update the dart version, the above point not satisfied using the command.
dart pub upgrade --null-safety dart pub get
Run the below command to know what are libs in your project needs to be upgraded to the latest null safety.
dart pub outdated --mode=null-safety
The latest column shows the current version if it’s in green that means dependency implemented null safety features if it red then the dependency owner needs to implement that.
Finally, run dart migration command which performs null safety migration on existing project(Existing project)
If your package is ready to migrate, then the tool produces a line like the following:
View the migration suggestions by visiting:
Note: Even after running
upgrade --null-safety command, you see the latest column section in red, which means a particular dependency hasn’t supported null safety yet, so that means you cannot migrate the project.
for detail read: https://dart.dev/null-safety/migration-guide
Good blog on Implementation of Null Safety: https://medium.com/flutterworld/flutter-null-safety-5d20012c2441
Answered By – Jitesh Mohite
Answer Checked By – Robin (FlutterFixes Admin)