how to enable –enable-experimental-mirrors in dart build?

Issue

My build of my projects are failing because they rely on mirrors and dart build out put tells me to use --enable-experimental-mirrors to try to use mirrors in dart2js code as it is. so if I run pub build --enable-experimental-mirrors all I get is Could not find an option named "enable-experimental-mirrors". Any hints much appreciated.

Solution

I haven’t tried this myself yet but maybe you can pass it as a command line option in the transformer config

transformers:
- $dart2js:
    commandLineOptions: [--enable-experimental-mirrors]

Answered By – Günter Zöchbauer

Answer Checked By – Jay B. (FlutterFixes Admin)

Leave a Reply

Your email address will not be published.