How do i add the master repo version of cloud_firestore plugin (inside flutterfire package) to my app's pubspec.yaml?

Issue

I need the disableNetwork() feature of cloud firestore in my flutter app. It is not available in the latest version (0.13.7) of cloud_firestore . It is available in the master repo of the git hub repository. I could not add the git link which directs to the cloud_firestore package because it is inside the repository flutterfire . So, how do i add it in my pubspec.yaml file.

  cloud_firestore: 
     git: https://github.com/FirebaseExtended/flutterfire.git

Solution

Use the path option as described here.

For example:

dependencies:
  kittens:
    git:
      url: git@github.com:munificent/cats.git
      path: path/to/kittens

Answered By – Richard Heap

Answer Checked By – Senaida (FlutterFixes Volunteer)

Leave a Reply

Your email address will not be published.