Flutter: 'package get' has not been run; 'Pub get' has not been run

Issue

I dowloaded a Flutter sample code for Catalog from git, which showing me a warning,

‘package get’ has not been run

‘Pub get’ has not been run

What does it mean? How to solve it? Should I ignore this warnings or Update dependencies as suggested with links in warning?

enter image description here

Solution

Dart is similar to node.
It has a pubspec.yaml which is the equivalent of package.json containing your dependencies and stuff.

And you need to download these dependencies, using pub get. Or on the case of flutter, using flutter packages get.

This warning is just here to reminds you that your dependencies aren’t downloaded

=> Click on Get Dependencies of the first warning

Answered By – Rémi Rousselet

Answer Checked By – Clifford M. (FlutterFixes Volunteer)

Leave a Reply

Your email address will not be published.