Flutter lower dart version


I’m getting the following error due to Dart version of my flutter setup when I run the flutter get packages command:

[project_name] flutter packages get Running “flutter packages get”
in project_name…
The current Dart SDK version is

Because project depends on intl_translation >=0.14.0+1 <0.17.0 which
requires SDK version >=1.12.0 <2.0.0, version solving failed. pub get
failed (1) exit code 1

My framework version:

Flutter 0.6.0 • channel beta • https://github.com/flutter/flutter.git
Framework • revision 9299c02cf7 (2 weeks ago) • 2018-08-16 00:35:12 +0200
Engine • revision e3687f70c7
Tools • Dart 2.1.0-dev.0.0.flutter-be6309690f

I would like to learn if there’s some kind of command to lower dart-sdk version of the flutter framework, thanks in advance.


In the Flutter install directory execute

git checkout v"0.5.0" // for example

You can check which versions are available in the Flutter GitHub repository https://github.com/flutter/flutter

Answered By – Roger Cuesta

Answer Checked By – David Goodson (FlutterFixes Volunteer)

Leave a Reply

Your email address will not be published. Required fields are marked *