Flutter: fatal error: 'Flutter/Flutter.h' file not found

Issue

Xcode’s output: ↳
In file included from /Users/dani/development/flutter/.pub-cache/hosted/pub.dartlang.org/url_launcher-6.0.3/ios/Classes/FLTURLLauncherPlugin.m:7:
/Users/dani/development/flutter/.pub-cache/hosted/pub.dartlang.org/url_launcher-6.0.3/ios/Classes/FLTURLLauncherPlugin.h:5:9:
fatal error: ‘Flutter/Flutter.h’ file not found
#import <Flutter/Flutter.h>
^~~~~~~~~~~~~~~~~~~
1 error generated.
In file included from /Users/dani/development/flutter/.pub-cache/hosted/pub.dartlang.org/shared_preferences-2.0.5/ios/Classes/FLTSharedPreferencesPlugin.m:5:
/Users/dani/development/flutter/.pub-cache/hosted/pub.dartlang.org/shared_preferences-2.0.5/ios/Classes/FLTSharedPreferencesPlugin.h:5:9:
fatal error: ‘Flutter/Flutter.h’ file not found
#import <Flutter/Flutter.h>
^~~~~~~~~~~~~~~~~~~
1 error generated.
Command CompileSwift failed with a nonzero exit code
Command CompileSwift failed with a nonzero exit code
note: Using new build system
note: Building targets in parallel
note: Planning build
note: Constructing build description

flutter doctor:

[✓] Flutter (Channel stable, 2.0.5, on macOS 11.2.3 20D91
    darwin-x64, locale en-GB)
[✓] Android toolchain - develop for Android devices (Android
    SDK version 30.0.3)
[✓] Xcode - develop for iOS and macOS
[✓] Chrome - develop for the web
[✓] Android Studio (version 4.1)
[✓] Connected device (3 available)

• No issues found!

I tried all solutions proposed here without luck:
https://github.com/flutter/flutter/issues/16036

All dependencies updated

Solution

This is a matter of finding a library on our app that doesn’t support null safety. We can do several things after identify it:

  • Ask on its repo to get support for null safety
  • Use a different library that supports this
  • Try to fix it ourselves

stackoverflow.com/a/33509278/4858133

Answered By – Dani

Answer Checked By – Robin (FlutterFixes Admin)

Leave a Reply

Your email address will not be published.