Dependency issue Dart

Issue

I am brand new to dart and I am attempting to include “Buckshot: ‘any'” into my yaml file. Unfortuanately I am getting a dependency error when I run pub install. I am sure that this is a very simple problem but any help would be appreciated.

Thank you,
Craig

Error:

Running pub install ...
Pub install failed, [1] Resolving dependencies...
Incompatible dependencies on 'logging':
- 'web_ui' depends on it from source 'hosted'
- 'buckshot' depends on it from source 'sdk'

Pubspec.yaml

name:  TestName
description:  A sample application

dependencies:
   hipster_mvc: 0.2.2
   web_ui: ">=0.2.10 <0.2.11"
   buckshot: 'any'

Solution

The problem comes from incompatible dependencies on the same package. web_ui is looking for logging package in pub and buckshot is looking for logging in dart:sdk.

Some times ago, SDK packages have been moved on pub.dartlang.org.

The hosted version of buckshot looks quite old (0.1.3) and does not handle that modification. However, the last version of the project on github does. So you can use the most recent version of Buckshot use the following dependencies :

dependencies:
  hipster_mvc: 0.2.2
  web_ui: ">=0.2.10 <0.2.11"
  buckshot:
    git: git://github.com/prujohn/Buckshot.git

Answered By – Alexandre Ardhuin

Answer Checked By – Marie Seifert (FlutterFixes Admin)

Leave a Reply

Your email address will not be published.