Dart Ubuntu Server 14.04 how to install missing library for Dartium

Issue

I’m attempting to port a dart project from Ubuntu 12.04 to another machine with Ubuntu Server 64 bit 14.04. I installed a new version of Dart Editor, etc. and copied my code over.

So far it appears to work except when I attempt to run the web code in Dartium. I receive an error message that my machine needs to be prepared for Dart – specifically it can’t find libudev.so.O.

How do I install that. I’m using a minimal Gnome GUI.

Solution

That version of libudev is not shipped with Ubuntu 14.04. You can try to create a symlink to the new version and see if it works:

sudo ln -s /lib/x86_64-linux-gnu/libudev.so.1 /lib/x86_64-linux-gnu/libudev.so.0

Or you can download that package from http://packages.ubuntu.com/precise/libudev0 (12.04 version) and install it in your system. I have not tried it, but as this package basically only contains libudev0 library itself and a symlink, it should work as well.

Answered By – Salem

Answer Checked By – Katrina (FlutterFixes Volunteer)

Leave a Reply

Your email address will not be published.