dart – its_all_about_you tutorial error

Issue

I am trying to run the latest version of its_all_about_you with the latest version of Dart Editor/SDK and I am getting this error. I copied the latest source from github

Internal error: 'http://.../web/out/packages/web_ui/src/linked_list.dart': 
Error: line 72 pos 29: cannot resolve class name 'IterableBase' from 'LinkedList'
class LinkedList<E> extends IterableBase<E> {

Does anyone know what the problem is and how to fix it? And for future reference how would one go about debugging the issue?

Solution

This looks like a version mismatch. Could you please verify that your sdk (comes with the editor) is up to date.
If the error persists after an upgrade, post the version number of your editor and try the following (untested) example:

import 'dart:collection';
class A extends IterableBase { get iterator => null; }
main() { new A(); }

In recent versions of Dart this should work.

Answered By – Florian Loitsch

Answer Checked By – Marie Seifert (FlutterFixes Admin)

Leave a Reply

Your email address will not be published. Required fields are marked *