cannot run the flutter app after firebase connection

Issue

After i added the GoogleService-Info.plist file to Runner on xcode, I get this error.
(I work on an M1 Chip MacBook Air)
This is the error i get when i try to run the app

I uninstalled each cocoapods version, and installed again using the ARM version (sudo arch -x86_64 gem install cocoapods).
But nothing changed.

Edit: Just tried the pod install method inside the ios folder and this is what happened;

Analyzing dependencies
cloud_firestore: Using Firebase SDK version '8.11.0' defined in 'firebase_core'
firebase_auth: Using Firebase SDK version '8.11.0' defined in 'firebase_core'
firebase_core: Using Firebase SDK version '8.11.0' defined in 'firebase_core'
[!] CocoaPods could not find compatible versions for pod "cloud_firestore":
  In Podfile:
    cloud_firestore (from `.symlinks/plugins/cloud_firestore/ios`)

Specs satisfying the `cloud_firestore (from `.symlinks/plugins/cloud_firestore/ios`)` dependency were found, but they required a higher minimum deployment target.

[!] Automatically assigning platform `iOS` with version `9.0` on target `Runner` because no platform was specified. Please specify a platform for this target in your Podfile. See `https://guides.cocoapods.org/syntax/podfile.html#platform`.

Solution

Final edit: I solved it thanks to this issue. The problem was that there’s no Podfile.lock in the /ios folder.

Answered By – Furkan Suren

Answer Checked By – Terry (FlutterFixes Volunteer)

Leave a Reply

Your email address will not be published.