I keep getting below error after I upgrade my Dart SDK. It seems webdev package has been upgraded from version 2.0.5 to 2.0.6. However I can’t run my project now,
"G:\Program Files\Dart\dart-sdk\bin\pub.bat" global run webdev build --output=web:build webdev could not run for this project. This version of webdev does not support the `build_daemon` protocol used by your version of `build_runner`. Please add a dev dependency on `build_daemon` with constraint: >=1.0.0 <2.0.0 Process finished with exit code 78
I tried by following error messages hints but couldn’t help!
And then, I generate a new project using Dart’s project generator called stagehand, same there.
I went through this last night. Had to deactivate webdev
pub global deactivate webdev
Then activate with a specific version (2.0.1 in my case)
pub global activate webdev 2.0.1
I didn’t try a different version as 2.0.1 was giving success and I wanted to get through completing my sample app. There are some interesting reads about how 2.0.6 was supposed to fix some things, but it’s requiring build_daemon version 1 whereas the default Angular dart sample I was using was requiring 0.5.0.
Answered By – Robert Larson
Answer Checked By – Marilyn (FlutterFixes Volunteer)